inohilog

/var/log/inohiro

Ubuntu(10.04 LTS) で mysql2 のインストールに失敗する件

  • Ubuntu(10.04 LTS) で mysql2 のインストールに失敗する件
    • bundle install などで mysql2 をインストールしようとしたら、以下のようなエラーが出た
Installing mysql2 (0.3.6) with native extensions /home/inohiro/.rvm/rubies/ree-1.8.7-2011.03/lib/ruby/site_ruby/1.8/rubygems/installer.rb:533:in `build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)

        /home/inohiro/.rvm/rubies/ree-1.8.7-2011.03/bin/ruby extconf.rb 
  • libmysqlclient-dev をインストールすれば良い
  • (前にも同じような内容の記事を書いたような)