inohilog

/var/log/inohiro

Linux

研究室の共用サーバーでtmuxを使いたい

研究室の共用サーバーで tmux を使いたい(root 権限持ってない) ここを参考に,libevent と ncurses を $HOME/bin に作って,configure まで上手くいったが,make で失敗する 非root権限でHOMEにtmuxを入れた tmux 使えるとうれしいが,より優先しないとい…

mmm-mode on Ubuntu 12.04

*** I can't use jsp(mmm) mode currently *** I want to use syntax highlighting when edit *.jsp file According to the following page, we can use mmm-mode reference: http://sakito.jp/moin/moin.cgi/MMM-mode $ unxip mmm-mode.tar.gz $ cd m…

Mondrian OLAP on Ubuntu Server 12.04

setting JAVA_HOME environment variable # ls -l /usr/lib/jvm/ total 4 lrwxrwxrwx 1 root root 14 Jul 17 15:42 java -> java-7-oracle/ drwxr-xr-x 8 root root 4096 Jul 10 20:21 java-7-oracle # # for Mondrian OLAP #export JAVA_HOME=/usr/lib/jvm/…

git pull/push to github.com in proxy environment

git pull/push to github.com in proxy environment install connect-proxy (connect command) "$ sudo aptitude install connect-proxy" write settings in ~/.ssh/config use 'ssh.github.com:443' if proxy server denies connecting to 22 port (squid (…

fail to start mysql on Ubuntu 12.04 (Desktop)

fail to start mysql on Ubuntu 12.04 (Desktop) We have to re-install 'mysql-common' package "$ sudo aptitude purge mysql-server-5.5 mysql-common" you need to backup your data (/var/lib/mysql/*) "$ sudo aptitude install mysql-server-5.5" MyS…

setting up my environment for research experiment

setting up my environment for research experiment Ubuntu 12.04 visudo modified /etc/apt/sources.list $ sudo aptitude update $ sudo aptitude upgrade -y $ sudo aptitide install emacs23-nox, install build-essential (, open-vm-tools) install z…

ftp.riken.go.jp/ubuntu

I should replace with emacs. root@ubuntu /etc/mysql # cat /etc/apt/sources.list #deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/main/binary-i386/deb http://ftp.riken.go.jp/Linux/ubuntu/ precise ma…

Ubuntu の source.list を編集する

ubuntu server 10.04 をインストールしたら,いちいち us.archive.ubuntu.com までパッケージを見に行っていたので 他にVMで2つ 10.04 インストールしているが,us.~ を見に行くのは英語でインストールしたからかな? /etc/apt/source.list を編集(元のファ…

最近(?)zshを使い始めました

最近と言っても,2,3月ごろから oh-my-zsh というのを知って theme ファイルとか共有されてる: https://github.com/robbyrussell/oh-my-zsh/wiki/themes 自分で改変したテーマ: https://github.com/inohiro/dotfiles/blob/master/inohiro.zsh-theme rvm で r…

CentOS(5.7)にRuby(1.8.7),RubyGems(1.3.7)を導入.ついでにrvmも

x86_64, CentOS 5.7 研究用に使ってる $ cat /etc/redhat-release CentOS release 5.7 (Final) $ uname -a Linux localhost.localdomain 2.6.18-274.7.1.el5 #1 SMP Thu Oct 20 16:21:01 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux $ cat /proc/version Linux…

CentOS 5.7 で Emacs 23.1.1 を make した

(CentOSなので)使ってたEmacsが21.4とかで、もうちょっとなんとかしたい $ wget ftp://ftp.gnu.org/pub/gnu/emacs/emacs-23.1.tar.gz $ tar cvfz emacs-23.1.tar.gz ./configure, make ちなみに、たとえGUI環境でもTerminalで使うので、"./configure --wit…

Ubuntu Server を pxe(netboot)+preseed で全自動インストールする

日記(2011.08.29)の続き 15台くらい同じOS(Ubuntu Server 11.04)をインストールしたい PXEブートを利用する preseed.cfg ファイルを用意しておくと、途中の入力を省略できる apt-mirror を用意しておくと、各々のインストール時に外部のミラーサーバを見…

IPアドレスの固定

CentOS /etc/sysconfig/network-scripts/ifcfg-eth0 あたりをいじる sudo /etc/init.d/network restart Ubuntu /etc/network/interfaces をいじる sudo /etc/init.d/networking restart

CentOS netinstall memo

ftp://ftp.riken.jp/Linux/centos/5.6/isos/(architecture)/CentOS-5.6-(architecture)-netinstall.iso web site name: ftp.riken.jp CentOS directory: Linux/centos/5.6/os/(architecture)

日記

研究室 昨日のミーティングのやり取りについてMLへメール 先生2人へメール Railsのバグっぽいものについて質問 http://stackoverflow.com/questions/6774007/rails2-3-set-session-expire-does-not-work RDF-3Xを動かすマシンをセットアップ AMD64 のマシン…

Ubuntu(10.04 LTS) で mysql2 のインストールに失敗する件

Ubuntu(10.04 LTS) で mysql2 のインストールに失敗する件 bundle install などで mysql2 をインストールしようとしたら、以下のようなエラーが出た Installing mysql2 (0.3.6) with native extensions /home/inohiro/.rvm/rubies/ree-1.8.7-2011.03/lib/rub…

Ubuntu10.04を10.10にアップグレードする

日常的にUbuntu10.04を使っているのですが、最近リリースされた10.10にアップグレードする方法。id:mariliameloに教えてもらいました。 System > Administration > Update Manager でアップグレードを実行すればいいのですが、10.04がLTSの為、「LTSじゃない…

Wordpressで画像をアップロードしたときに、リサイズするオプションが選択できないときは、PHPのライブラリが足りてない!からみたい

超タイトル長くしてみた。Wordpressが超絶便利で、情報科学類誌WORDのWeblogを、yet another wordpressということでWordpressで構築しています。 WORD Press で、最近サーバーOSをFree BSDからUbuntuに変更したのですが、そうしたら画像をアップロードしたと…

PACKAGE_NAME がインストールされているか探す

Debian系。 $ dpkg-query -l PACKAGE_NAME | grep iiとするとdpkg(を使った、aptitudeとかapt-getとか)でインストールしている場合、結果が出るかも。aptitude show でも出るかも。 教えた貰ったサイト Command to check if a package is already installe…

Ubuntu 10.04 に Imagemagick と rmagick をインストールする

Ubuntu 10.04 に Imagemagick と rmagick をインストールした。と言っても、Imagemagick自体は既にインストールされていたようで、問題なかったが、rmagickのインストールでつまずいた。 imagemagick の確認 $ aptitude show imagemagick パッケージ: image…

新しくLinuxをインストールしたときによくやる設定メモ

新しく(VMなどで)Linuxをインストールしたときによくやる設定メモ。よくわからなくなるので。 ホスト名を変更する /etc/hostname を編集する 参考: インストール後のホスト名の変更 - かえでのWebログ 新しくフォントを追加する /usr/share/fonts にコピー…

UbuntuでRailsの環境

前にやったときのメモ(OpenIDライブラリ、プラグインのインストールとか) 最近9.10から10.04にアップグレードしたUbuntuでRails 2.3.8 + jpmobileの環境を作ろうとしているんだけど、どうもうまくいかない Ubuntuの場合、Railsのインストールはgemじゃなく…

"uninitialized constant MysqlCompat::MysqlRes"

タイトルのエラー("uninitialized constant MysqlCompat::MysqlRes")が出る とりあえずメモ http://groups.google.com/group/rubyonrails-talk/browse_thread/thread/8e340e616b5b29f?pli=1 inohiro@ubuntu:~$ sudo aptitude install libmysqlclient15-dev…

sudo gem install mysql に失敗するとき

Ubuntu で Rails のDBに MySQLを使いたい PostgreSQL, sqlite3 ばっかり使ってる rake db:migrate してもエラーがでる -> mysql を使う環境が整ってないんじゃ... $ rake db:migrate ERROR: Failed to build gem native extension.inohiro@ubuntu:~$ sudo ge…

UbuntuにPostgreSQLをインストール

大体こんな感じ。メモ $ sudo aptitude install postgresql-8.4 postgresql-client-8.4 $ sudo passwd postgres $ sudo aptitude install ruby1.8-dev $ sudo gem install postgres

bash のプロンプトをいじる

Ubuntuのbashで、デフォルトの設定のままだと深いディレクトリに入ったときにこんなふうになってしまいます。 inohiro@ubuntu:~/Projects/aaa/trunk/openid_sample/app/controller$ 長い。 プロンプトの設定は.bashrcや.bash_profileで行えばよいとのことで…

apt-getではなくaptitudeの利用が推奨されてるとかないとか

「Ubuntuではapt-getを使うと便利です」的な記事を書いたところ、「最近はaptitudeを使うのが推奨されてるよ」的な発言をいただいたので。 apt-getではリストの更新とかサポートされなくなったとか。ほんと? APT HOWTO APT - Wikipedia Aptitude - Wikipedia…

Ubuntu版(?)Rails 2.1.x系だとバージョン情報の確認ができない

諸事情でUbuntuにRails 2.1.x系をインストールしたんですが、バージョン確認ができません*1。入っているRailsは2.1.0。 実際にはどんな感じかといいますと、 inohiro@ubuntu:~$ rails -v getopt: invalid option -- 'v' Terminating...とか、 inohiro@ubuntu…

メモ

diff/patch Tips patch - Wikipedia GNU utilities for Win32 UnxUtils - sourceforge.net Windows+symfony1.1でproject:deployを動かすためのパッチ - 秋元@ならべて.com Windowsでもtailコマンドを使う - phpspot開発日誌 Windowsでtailコマンドを使う - …

MSが反Linuxサイト開設

ふーん 米MSが反Linuxの新サイト開設 http://www.atmarkit.co.jp/news/200708/24/ms.html